.js im head aufrufen

#1
moin,

eine einfache frage:

ich versuche den wordpress audioplayer (standalone version) in ein html dokument einzubinden, und verfahre dabei genau so, wie in der anleitung vorgeschlagen (http://wpaudioplayer.com/standalone/)

natürlich funktioniert es nicht so wie es sollte. im browser sehe ich die beiden script einbindungen aus dem head

Code:
<script type="text/javascript" src="path/to/audio-player.js"></script>
<script type="text/javascript">
AudioPlayer.setup("http://yoursite.com/path/to/player.swf", {
width: 290
});
</script>
nur als text – und dahinter dann logischweise auch das "alternative content"

sprich also, das laden/verlinken/einbinden (oder wie auch immer man das nennt), ist gescheitert.

nachdem ich nun mehrfach überprüft habe, ob an der synthax oder den pfaden etwas falsch ist, oder ob man die pfade ggf anders schreiben muss, als in der anleitung gezeigt wird, weiss ich nun nicht mehr weiter.

sicherlich kennen viele dieses oder ähnliche scripte auswendig und wissen sofort, was ich falsch mache.

die struktur, die ich verwende, ist simpel, sie sei hier trotzdem erwähnt:

meinserver.de/ordner/index.html
meinserver.de/ordner/meinemusik.mp3
meinserver.de/ordner/audio-player/audio-player.js
meinserver.de/ordner/audio-player/player.swf

da in den getesteten browsern das gleiche script auf fremden websites funktioniert, muss ich etwas übersehen haben.
 
Zuletzt bearbeitet:

Bratkartoffel

gebratene Kartoffel
Premium-User
#2
Hi,

zwischen "script" und "type" gehört ein Leerzeichen.

HTML:
<script type="text/javascript" src="path/to/audio-player.js"></script>
<script type="text/javascript">
AudioPlayer.setup("http://yoursite.com/path/to/player.swf", {
width: 290
});
</script>
Grüße,
BK
 
#4
der dargestellte text im browser beginnt mit übrigens mit "AudioPlayer.setup..."
es muss also nicht stimmen, wie ich oben vermutete, dass schon das verweisen auf das .js nicht geht. (?)