JPA, Eclipselink & MySQL: Kein Zugriff auf Tabellenspalten

zeromancer

Erfahrenes Mitglied
Hallo zusammen!
Ich bin noch recht neu im Thema, aber es scheitert schon an der Vorbereitung.
Ich habe eine MySQL 5.x DB auf einem Server, die Connection ist eingerichtet in Eclipse.
Leider sehe ich im Database Explorer keine Tabellenspalten (die Tabellen schon).
Somit kann ich auch keine Entity aus der Tabelle erzeugen, da Eclipse nicht die Spalten "sieht".

Die Gegenprobe mit einer Oracle-DB klappt problemlos. Nur kann und will ich keine Oracle-DB benutzen, es sollte schon mit MySQL laufen.

Irgendwelche Tipps, was ich noch tun kann?
Ist das ein Bug im JPA/Eclipselink/MySQL?

Daten: Eclipse Indigo, JPA mit Eclipselink, Persistence 2.0.4, JDBC für MySQL 5.1.22, MySQL-DB 5.x (genaue Version habe ich gerade nicht zur Hand)
 

saftmeister

Nutze den Saft!
Eclipse hat eine Error-Console. Zu finden unter "Window" => "Show View" => "Error Log". Steht dort evtl. irgendwas relevantes drin?

Ich habe es gerade bei mir getestet, funktioniert mit Juno, MySQL Connector/J (http://dev.mysql.com/downloads/connector/j/) und Eclipselink 2.4.1 tadellos, mittels Zugriff auf das 'mysql.test' Schema. Tabellen werden problemlos angezeigt auch die Spalten in den Tabellen inkl. Constraints. Trigger, Dependencies und Indizes habe ich keine definiert, also ist das leer.

Vielleicht genügt es bereits, wenn du die Eclipse und Eclipselink mal updatest.
 

zeromancer

Erfahrenes Mitglied
Hallo saftmeister!
Danke für den Hinweis. Das Error Log ist jedoch leer und - oh Wunder - nun sehe ich Tabellenspalten!
Was habe ich gemacht? Eine 2. Tabelle angelegt und ein Foreign Key definiert - sonst nichts.
Eclipse, das unbekannte Wesen...
 

Neue Beiträge