JDK unter WinXP???

HAL

Erfahrenes Mitglied
Wie bekomme ich das jdo unter winxp zum laufen, so dass ich über die cmd per "javac xyz.java" kompilieren kann usw? ich kann ja keine pfadangaben in der autoexec.bat machen, weil es die in winxp nicht in der forum gibt...
 

Christian Fein

Erfahrenes Mitglied
Rechtsklick auf Arbeitsplatz.

Reiter Erweitert auswählen

Klick auf Umgebungsvariablen

Da gibt es unter System Variablen
eine Variable namens Path.
Ind der stehen mehrere durch ; getrennte Pfade drinne.

Dort setzt du den Pfad des java/bin verzeichnis ans ende hinzu durch.
Sprich
path=[viele viele pfade];c:\j2sdk1.4.0_02\bin
 

Thomas Darimont

Erfahrenes Mitglied
Moin!

...wenn man jedoch keinen Classpath als Umgebungsvariable registriert, nimmt sich das JDK die Informationen über das Java Verzeichnis direkt aus der Registry...

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.X
-->JavaHome
...

man muss dazu die Laufzeitumgebung aber zuerst noch in der Systemsteuerung unter Java-Plugin anpassen...

Gruss Tom
 

HAL

Erfahrenes Mitglied
Original geschrieben von HolyFly
Rechtsklick auf Arbeitsplatz.

Reiter Erweitert auswählen

Klick auf Umgebungsvariablen

Da gibt es unter System Variablen
eine Variable namens Path.
Ind der stehen mehrere durch ; getrennte Pfade drinne.

Dort setzt du den Pfad des java/bin verzeichnis ans ende hinzu durch.
Sprich
path=[viele viele pfade];c:\j2sdk1.4.0_02\bin

danke!
 

Airwave

Grünschnabel
Nur bei mir ist in C: nicht so ein verzecihnis und ansonsten ist das auch nicht direkt auf der platte hab auhc Win XP Prof. + Servp. 1

C:\>javac HelloDan.java
Der Befehl "javac" ist entweder falsch geschrieben oder
konnte nicht gefunden werden.


Das kommt wenn ich einfach
:
Dort setzt du den Pfad des java/bin verzeichnis ans ende hinzu durch.
Sprich
path=[viele viele pfade];c:\j2sdk1.4.0_02\bin

mache


und das ist meine versíon

C:\>java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-b28)
Java HotSpot(TM) Client VM (build 1.4.2-b28, mixed mode)

thx 4 help
 

Thomas Darimont

Erfahrenes Mitglied
Servus!

Bist du sicher, dass du auch die SDK Variante runtergeladen hast? Bei der JRE (Java Runtime Environment 1.4.2) [Laufzeitumgebung) ist der javac Compiler nicht dabei ... -> SDK Downloaden ...

Gruß Tom
 

Airwave

Grünschnabel
ah thx das wird mein fehler gewesen sein :D

könnt ihr mir ein gutes Buch für Anfänger empfehlen?

und evtl ein tool zum java programmieren.