Input-Feld von Typ file führt zu 302


Kalito

Erfahrenes Mitglied
Hallo,

ich nutze für ein Projekt das Framework cakePHP (daher kann es mit Code etwas schwierig werden). In der Regel kommt bei einem Funktionsaufruf via Get oder POST ein HTTP 200 zurück und alles ist fein. Wenn ich aber in Formular ein Input-Feld von Typ file einbaue, dann wird der POST-Teil der Funktion des Scripts korekt abgearbeitet, aber es kommt ein HTTP 302 zurück, was dazu führt, dass die Seite mittels GET noch einmal aufgerufen wird und nicht der eigentliche Redirekt.

So langsam gehen mir die Ansätze aus, warum dieses eine Feld mir solche Probleme bereitet. Hat einer von euch eine Idee?
 

Kalito

Erfahrenes Mitglied
Kleines Update:
Normalerweise habe ich local folgende vhost-Einstellungen:

Apache-Konfiguration:
<VirtualHost *:80>

    ServerAdmin p.kahle@sachsenlotto.de

    DocumentRoot "C:/xampp/htdocs"

    ServerName localhost

    ErrorLog "logs/error.log"

    CustomLog "logs/access.log" common

</VirtualHost>


<VirtualHost slm-local:80>

    ServerAdmin p.kahle@sachsenlotto.de

    DocumentRoot "C:/xampp/htdocs/slm"

    ServerName slm-local

    ErrorLog "logs/slm-local-error.log"

    CustomLog "logs/slm-local-access.log" common


    <Directory />

        Options FollowSymLinks

        AllowOverride All

    </Directory>

</VirtualHost>


<VirtualHost slm-local:443>

    DocumentRoot "C:\xampp\htdocs\slm"

    ServerName slm-local

    

    SSLEngine On

    SSLCertificateFile "C:/xampp/apache/conf/ssl.crt/server.crt"

    SSLCertificateKeyFile "C:/xampp/apache/conf/ssl.key/server.key"

    

    <Directory "C:\xampp\htdocs\slm">

        Order allow,deny

        Allow from all

    </Directory>

</VirtualHost>
nun habe ich die unteren beiden Blöcke auskommentiert und mit dem Aufruf http://localhost/slm statt slm-local/ wird beim Absenden des Formulars kein 302 zurück geschickt.
 

merzi86

Erfahrenes Mitglied
Ich kenne CakePHP nicht und daher auch nicht die genaue Arbeitsweise.
Ist das verhalten manchmal nur bei der Normalen HTTP Seite zu beobachten und bei der HTTPs nicht?

Wenn ja Kommentiere mal das "Options FollowSymLinks" aus. Vielleicht erstellt CakePHP SymLinks, welche der Apache folgt und dadurch dieses Verhalten entsteht.