1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Https/SSL zerschießt Webseite

Dieses Thema im Forum "HTML & XHTML" wurde erstellt von elPlantador, 14. November 2014.

  1. elPlantador

    elPlantador Mitglied

    Guten Morgen!

    Ich habe folgendes Problem: Kürzlich wurde ein SSL Zertifikat für unsere Webseite eingerichtet. Wenn ich diese nun mit https:// aufrufe, lädt das Javascript nicht mehr und Javascript basierte Sachen (z.b. ein Slider) wird zerschossen. CSS funktioniert. Hat jemand nen Tipp was ich da versuchen könnte?

    Viele Grüße und Danke!
     
  2. SpiceLab

    SpiceLab ZENmechanic Premium-User

    Bezieht die Webseite eine JS-Bibliothek von einem Fremdserver (z.B. ajax.googleapis.com/.../.../)?

    Wie sind die JS-Dateien im HTML-Code referenziert?
     
  3. elPlantador

    elPlantador Mitglied

    Von einem Fremdserver werden keine JS-Bibliotheken bezogen, liegen alle aufm Webspace.

    Wie meinst Du das genau?
     
  4. sheel

    sheel I love Asm Administrator

    Sind die JS-Pfade, die im HTML eingetragen sind, einfach zB. "bla.js" oder "http://www.blub.de/ordner/bla.js"?
    Kann man sich die Seite irgendwo live anschauen?
     
  5. SpiceLab

    SpiceLab ZENmechanic Premium-User

    Ob es sich um vollständige URIs, oder absolute / relative Pfadangaben relativ zum Basis-URI handelt?

    Edit: Siehe die beiden genannten Beispiele von @sheel ;)
     
  6. elPlantador

    elPlantador Mitglied

    Achso, verstehe. ;)

    Die Pfade sind absolut eingetragen.

    Das wäre die Seite.
     
  7. Alice

    Alice Erfahrenes Mitglied

    Vorweg: Ich bin in Sachen JS (und alle "Unterarten") ein völliger Anfänger. Sprich: Hab kaum Plan davon.

    Aber... (vielleicht hilft es ja)

    Dein Quelltest:
    HTML:
    1. https://www.manager-institut.de/fileadmin/js/jquery_sf.js?1375518956
    Sucht man nun in dieser ".js" Datei nach "http" gibt es viele Treffer. Vielleicht liegt hier das Problem!?

    PS: Mein Browser erkennt Deine Webseite "als Gefahr"...

    Edit:

    Wenn ich es richtig verstanden habe, könnte auch so etwas helfen:
    HTML:
    1. <script src="//www.example.com/whatever.js" type="text/javascript"></script>
    2. <img src="//www.example.com/someimage.png" alt="whatever"/>
    3. <link href="//www.example.com/styles.css" rel="stylesheet"/>
    Aber nicht böse sein, wenn ich komplett daneben liegen sollte. :D

    Edit:

    Wenn ich Deine Webseite im IE öffne und die Warnung ignoriere und "alle Inhalte anzeigen" anklicke, sieht die Seite super aus. Genau wie die http Seite.

    Edit:

    Wenn ich im Firefox links neben der URL (Adresszeile) klicke, öffnet sich ein kleines Fenster wo ich "blockieren" aufheben kann. Dann ladet die Seite auch Einwandfrei wie im IE.
     
    Zuletzt bearbeitet: 14. November 2014
  8. sheel

    sheel I love Asm Administrator

    Also, die Pfade sind tatsächlich ganz schön durcheinander.

    Sobald man seinem Browser ausreichend versichert hat, die Seite tatsächlich öffnen zu wollen,
    gibt es grob folgende Kategorien, woher Sachen geladen werden sollen:
    a) Die genannte Domain selber (ohne "www"), teilweise mit HTTPS, aber teilweise auch noch HTTP.
    b) Die Subdomain "blog", nur HTTP.
    c) Viele der Dateien, die von der Hauptdomain angefragt werden, haben eine 301-Umleitung auf blog.
    Auch HTTP. Auch ohne dem Sicherheitsproblem wäre da was zum Nachbessern
    d) fonts.googleapis.com, auch nur HTTP
    e) i1.ytimg.com (Bilder von Youtube), auch nur HTTP.

    Das ganze HTTP muss weg. Scheinbar sind im ganzen Seitencode viel zu viel absolute Pfade verstreut.

    PS: Das Seitenzertifikat ist von euch selbst erzeugt?
    So gehen die Browserwarnungen nie weg.
     
    Zuletzt bearbeitet: 14. November 2014
    SpiceLab gefällt das.
  9. SpiceLab

    SpiceLab ZENmechanic Premium-User

    Zuletzt bearbeitet: 14. November 2014
  10. elPlantador

    elPlantador Mitglied

    Vielen Dank für tollen Antworten. Ich hatte leider noch keine Zeit etwas rumzusprobieren - scheint doch mehr Aufwand zu sein, als gedacht.
    Ich werde die nächsten Tage mal etwas rumprobieren und dann Rückmeldung geben.

    Das ist das SSL Standardzertifikat von der Domainfactory.
     
Die Seite wird geladen...