Hiillfeeee


#1
oh mann, ich checke dieses flash5 ganz und gar nicht... mein flash4 funzt nich mehr, drum muss ich das 5er nehmen

also, mein problem:

ich habe einen film gemacht, darin eine eigene "filmsequenz" um sie schön ausrichten zu können.
Nun wenn ich die swf hochlade und im inet ansehen will dauert das laden ca 1 minute, ich denke statt gleich mit dem abspielen zu starten lädt flash erst die kleine filmsequenz [die den ganzen eigentlichen film beinhaltet].

ich habe nun 3 szenen geamcht, und die filmsequenz "auseinandergeschnitten". in die erste szene den ersten teil, *da drin ist der button für "weiter" -> der film stopt dort, und mit "weiter" soll dann in die zweite szene gesprungen werden und die dortige filmsequenz gestartet werden.

Ich hab auf dem button die aktion

on (release) {
gotoAndPlay ("teil_2", 1);
play (); //oder was das ist, evtl. auch "0" :(
}

ich kenn mich null mit action script aus, aber das sollte doch funzen?!?!
"teil_2" heisst die zweite ebene, da drin ist im ersten schlüsselbild der zweite teil der ani, wieder in einer eigenen filmsequenz. ich kann nicht alles rauskopieren, also direkt in den film, weil es dort um ca 200 pixel verschoben ist....... *argl*

HILFE !!!!!

.:döS:.
 
F

First Virus

#2
on (release) {
gotoAndPlay ("teil_2", 1);
play (); //oder was das ist, evtl. auch "0" :(
}
Also das play nimmste da mal raus denn das bewirkt das er einfach in der Szene in der er grade ist also wo der button ist einfach losspielt und beim nächsten stop wieder aufhört.

teil_2 ist wie ich das versatnden habe die zweite Szene??, wenn ja dann muss die auch so heißen.

Wenn du in der zweiten Szene nur einen frame hast in dem sich ne filmsequenz befindet dann mus du das gotoAndPlay in ein gotoAndStop umändern denn wenn da nur ein frame ist und er abspielen soll springt er in die nächste Szene.

Im klar text soll das heißen:

erste Szene:
name irgendwas

Button:

on (release){
gotoAndStop ("teil_2", 1);
}

zweite Szene:
name teil_2

filmsequenz:
frame 1:
play();


so jetzt sollte es gehen, was habe ich gemacht???.

Ganz einfach da wenn man auf den button klick er ja dann in die 2.Szene springt und stoppen soll braucht die filmsequens nen play da diese meineserachtens auch gestoppt wird.

verstanden??? wenn nein dann einfach nochmal posten
 
#3
hm

meine button aktion ist jetzt

on (release) {
gotoAndStop ("teil_2", 1);
}

aber der film springt dann in die erste szene, [also wieder die selbe] und stoppt.
szene zwei heisst teil_2

mmmh

ich muss jetzt essen , werd nachher etwas rumprobieren, danke für die antort, wenn dir was einfällt posten bitte :)

.:döS:.
 
F

First Virus

#4
ne erweiterung

mach einfach mal in der zweiten Szene auf den ersten frame ne bildmarkierung ich nenne sie einfach mal hossa :p

dann must du in deinem button statt gotoAndStop ("teil_2", 1);,
gotoAndStop ("teil_2", "hossa");

dann solte es aber funtzen, wenn nicht dann weiß ich auch keinen rat mehr.
 
#5
naja, ich hab jetz ne andere lösung:

ich schätze es ging nich weil die buttons in einer filmsequenz sind, [oder waren :)] und darum gar nicht nach aussen [teil_2] dringen, sondern nur in der filmsequenz wieder an den anfang springen.

ich hab jetzt den button aus der sequenz genommen und beim film soviele frames gemacht wie die filmsequenz bis zum button [> STOP] lang ist, dann den button in einen separaten layer getan, und auf dieses letzte frame getan.

dann so 5 frames weiter die filmsequenz "zweiter_teil" eingefügt [ aktion Stop() ] und auf dem button von vorher die aktion

on (release) {
gotoAndPlay ("szene 1", 205); // das schlüsselbild mit der "zweiter_teil" filmsequenz drin.
}

so funzt's und es ladtet wesentlich schneller.

danke auf jeden fall für die tipps!!

.:döS:.
 
F

First Virus

#6
man sag das doch gleich das der button in ner filmsequenz drin ist in dem falll must du nur die hauptzeitleiste ansprechen und zwar wie folgt:

_root.gotoAndStop ("teil_2", "hossa");
oder
_root.gotoAndStop ("teil_2", 1);


Was ist _root???

_root ist wiegesagt die hauptzeitleiste genau kann ich dir das auch net erklären aber das ist wie der flash syntax da hat man die hauptzeitleiste glaube mit ../ angesprochen oder so ähnlich

na ja jedenfalls mit der version wie du sie jetzt hast das er in den 205 frame springt ist viel zu viel unötiger "Dateispeicherfresser" :) hau einfach nur nen _root for das goto und alles ist gut :D