Formular wird nicht gesendet


#1
Hallo,

habe ein Formular was vorher ging jetzt in eine neue Seite eingebunden.

es wird nicht gesendet. Wer kann mir den Fehler erklären.

<?



}

if (($REQUEST_METHOD == 'POST') && ($action == 'send')) {



$site_name = "Australien Camper";

$site_email = "info@australien-camper.com";



if ($email == "")

{

echo "<font color=#333333><B>Ihre Anfrage konnte nicht verschickt werden!</B></font></td></tr></table>";

echo "<BR><br><font color=#FF0000> Fehler:</font><BR><b>Bitte füllen Sie alle erforderlichen Felder aus!</b>";

}

else

{

echo "<font color=#333333><CENTER><B>Ihre Anfrage ist verschickt!</B></font></td></tr></table>";

PRINT "<CENTER>";

PRINT "<P><BR><BR><BR><BR><BR><BR>";

PRINT "</CENTER>";

mail("$email", "$site_name Email Empangsbestätigung!", "

____________________________________________________________\n

Ihre Angaben:\n

Absender: $anrede $vorname $nachname\n

Geburtsdatum: $geburtsdatum\n

Anschrift:\n

$strasse-nr\n

$plz $ort\n

$land\n

Tel. tagsüber: $telefon\n

Email: $email\n\n



Gewünschtes Fahrzeug: $fahrzeug\n

Mietbeginn: $anmiettag $anmietmonat $anmietjahr\n

Anmietstation: $anmietstation\n

Mietende: $rueckgabetag $rueckgabemomat $rueckgabejahr\n

Rückgabestation: $rueckgabestation\n



Versicherung: $versicherung\n



Anzahl Mitreisende: $anz_mitreisende\n

Mitreisende 2: $anrede2 $vorname2 $nachname2\n

Geburtsdatum: $geburtsdatum2\n

Mitreisende 3: $anrede3 $vorname3 $nachname3\n

Geburtsdatum: $geburtsdatum3\n

Mitreisende 4: $anrede4 $vorname4 $nachname4\n

Geburtsdatum: $geburtsdatum4\n

Mitreisende 5: $anrede5 $vorname5 $nachname5\n

Geburtsdatum: $geburtsdatum5\n



Kommentar: $kommentar\n

____________________________________________________________");



#######################################################

# This below is the information which will

# be sent to the Administrator

#######################################################

mail("$site_email",

"$site_name Kontakt-Form",

"Name: $anrede $vorname $nachname\n

____________________________________________________________\n

Ihre Angaben:\n

Absender: $anrede $vorname $nachname\n

Geburtsdatum: $geburtsdatum\n

Anschrift:\n

$strasse-nr\n

$plz $ort\n

$land\n

Tel. tagsüber: $telefon\n

Email: $email\n\n



Gewünschtes Fahrzeug: $fahrzeug\n

Mietbeginn: $anmiettag $anmietmonat $anmietjahr\n

Anmietstation: $anmietstation\n

Mietende: $rueckgabetag $rueckgabemomat $rueckgabejahr\n

Rückgabestation: $rueckgabestation\n



Versicherung: $versicherung\n



Anzahl Mitreisende: $anz_mitreisende\n

Mitreisende 2: $anrede2 $vorname2 $nachname2\n

Geburtsdatum: $geburtsdatum2\n

Mitreisende 3: $anrede3 $vorname3 $nachname3\n

Geburtsdatum: $geburtsdatum3\n

Mitreisende 4: $anrede4 $vorname4 $nachname4\n

Geburtsdatum: $geburtsdatum4\n

Mitreisende 5: $anrede5 $vorname5 $nachname5\n

Geburtsdatum: $geburtsdatum5\n



Kommentar: $kommentar\n

____________________________________________________________");

}



}



?>
 
Zuletzt bearbeitet:

Kalito

Erfahrenes Mitglied
#4
  1. ok, Das Thema war als gelöst markiert. Daher wird jeder denken es wäre gelöst
  2. Bitte den Code in ein entsprechendes Code-Tag umschließen. Den Code da oben tut sich keiner an. Du findest die Tags unter Einfügen > Code
  3. Du hast das Formular in einen neue Seite eingebunden. Was geht nun genau nicht? Hast du das Script nur rüberkopiert oder auch was geändert
  4. Befindet sich die neue Seite auf dem gleichen Host/Server
 

Kalito

Erfahrenes Mitglied
#6
Wenn ich dir alles aus der Nase ziehen muss, dann vergeht mir die Lust zu helfen. Was ist mit den Punkten 2 und 4? Und bei Punkt 3 ist noch offen, was nun genau nicht funktioniert?
 

Neue Beiträge