Fehlermeldung durch runat-Attribut

chironex

Erfahrenes Mitglied
Hallo Leute,

ich habe ein kleines Problem: Wenn ich auf meiner aspx-Seite folgenden Code einbette, dann wird mir ordnungsgemäß das DHTML Edit Control von MS angezeigt:

Code:
<OBJECT id="dhtmleditctrl" style="WIDTH: 724px; HEIGHT: 328px" classid="clsid:2D360201-FFF5-11D1-8D03-00A0C959BC0A"
	VIEWASTEXT>
	<PARAM NAME="ActivateApplets" VALUE="0">
	<PARAM NAME="ActivateActiveXControls" VALUE="0">
	<PARAM NAME="ActivateDTCs" VALUE="-1">
	<PARAM NAME="ShowDetails" VALUE="0">
	<PARAM NAME="ShowBorders" VALUE="0">
	<PARAM NAME="Appearance" VALUE="1">
	<PARAM NAME="Scrollbars" VALUE="-1">
	<PARAM NAME="ScrollbarAppearance" VALUE="1">
	<PARAM NAME="SourceCodePreservation" VALUE="-1">
	<PARAM NAME="AbsoluteDropMode" VALUE="0">
	<PARAM NAME="SnapToGrid" VALUE="0">
	<PARAM NAME="SnapToGridX" VALUE="50">
	<PARAM NAME="SnapToGridY" VALUE="50">
	<PARAM NAME="UseDivOnCarriageReturn" VALUE="0">
</OBJECT>

Jetzt möchte ich aber auch serverseitig auf die Eigenschaften des Controls nach dem Postback zugreifen, weshalb ich das RUNAT Attribut einbaue:

Code:
<OBJECT id="dhtmleditctrl" style="WIDTH: 724px; HEIGHT: 328px" classid="clsid:2D360201-FFF5-11D1-8D03-00A0C959BC0A"
	runat="server" VIEWASTEXT>
	<PARAM NAME="ActivateApplets" VALUE="0">
	<PARAM NAME="ActivateActiveXControls" VALUE="0">
	<PARAM NAME="ActivateDTCs" VALUE="-1">
	<PARAM NAME="ShowDetails" VALUE="0">
	<PARAM NAME="ShowBorders" VALUE="0">
	<PARAM NAME="Appearance" VALUE="1">
	<PARAM NAME="Scrollbars" VALUE="-1">
	<PARAM NAME="ScrollbarAppearance" VALUE="1">
	<PARAM NAME="SourceCodePreservation" VALUE="-1">
	<PARAM NAME="AbsoluteDropMode" VALUE="0">
	<PARAM NAME="SnapToGrid" VALUE="0">
	<PARAM NAME="SnapToGridX" VALUE="50">
	<PARAM NAME="SnapToGridY" VALUE="50">
	<PARAM NAME="UseDivOnCarriageReturn" VALUE="0">
</OBJECT>

Laut den Beispielen im Internet läuft das ja so, aber ich bekomme jetzt folgende Fehlermeldung:

Parser-Fehlermeldung: GUID muss 32 Ziffern mit 4 Bindestrichen enthalten (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).


Daran habe ich ja nichts geändert. Ich versteh das nicht so wirtklich. Leider passiert mir das nicht nur beim DHTML Edit Control sondern auch beim TimePickerControl.

Habt Ihr eine Ahnung, woran das liegen kann?
 

Neue Beiträge