Fehler bei TortoiseGit "git did not exit cleanly (exit code 128) (109 ms @ 23.10.2015 06:42:20)"

Lampi

Grünschnabel
Guten Morgen!

Ich habe
  1. Tortoisegit für Windows heruntergeladen.
  2. Sofort darauf installiert. Habe das extra früh gemacht, damit mir nicht ein evtl. Update dazwischenkommt.
  3. Neues leeres Verzeichnis erstellt,
  4. rechtsklick --> Clone ausgewählt
  5. Meldung erhalten, dass git.exe nicht gefunden wurde. Natürlich keine Info, wie man da dran kommt.
  6. Herumgegoogelt, wo man git.exe herbekommt
  7. Bei github.org einen Client heruntergeladen. War nur ein Versuch, weil auch dort wieder keine vernünftige Information. Hat aber s.u. geklappt.
  8. Ins oben erstellte Verzeichnis zurückgegangen
  9. rechtsklick --> Clone ausgewählt
  10. keine Meldung erhalten, dass git.exe nicht gefunden wurde und vermutet, der Fehler sei damit behoben.
  11. URL eingegeben: https://github.com/openetcs/modeling
  12. alle weiteren Checkboxen unverändert (leer) gelassen.
  13. Sofort (d.h. ohne dass jegliche Downloads erfolgt wären) folgendes Ergebnis erhalten:
"git did not exit cleanly (exit code 128) (109 ms @ 23.10.2015 06:42:20)"
Sonst gar nichts.

Ich muss schon sagen "Eine absolut aussagekräftige Fehlermeldung. Ein Musterbeispiel an Useability. Super!"

Was habe ich falsch gemacht?


PS: Im Geschäft hat es gefunzt.
 
Zuletzt bearbeitet:

Lampi

Grünschnabel
Zweiter Versuch, dieses Mal (in der Nummerierung oben die 12) die Checkbox "recursive" markiert. Da gibt es keine Info, dass das evtl. sinnvoll wäre. Vor allem wäre es sinnvoll, das recursive als Standard herzunehmen

Jetzt wurden die Dateien heruntergeladen, nach gut 22 Minuten folgendes Ergebnis

Ergebnis: "git did not exit cleanly (exit code 128) (1433844 ms @ 23.10.2015 07:25:09)"

Immerhin habe ich jetzt die Files.

Andere Frage: Wenn ich die Fehlermeldung einfach ignoriere, was hätte das für Folgen?
 
Zuletzt bearbeitet: