explorer auf mac - java funktioniert nicht!

qXp

Grünschnabel
hallöle
Gelegentlich lassen sich Java-Funktionen mit dem I.Explorer 5.1.4 nicht aktivieren, obwohl ich in den Voreinstellungen Java aktiviert habe. MRJ 2.2.5 ist installiert. Das Java-Fehlerprotokoll zeigt z.B. das Folgende (s.u.) an - ich kann daraus leider nichst herauslesen; aber eine/r von Euch vielleicht? Ich arbeite mit einem g4 unter MacOS 9.1

Danke und Grüße:

qXp

"5/30/2003 @ 13:3:43 Java Exception: java.lang.NullPointerException - Stack Trace: java.lang.NullPointerException at java.awt.LightweightDispatcher.stopListeningForOtherDrags(Container.java ) at java.awt.LightweightDispatcher.dispose(Container.java) at java.awt.Container.removeNotify(Container.java) at java.awt.Window.dispose(Window.java) at java.awt.Frame.dispose(Frame.java) at com.apple.mrj.JManager.JMAppletViewer_OLD.setState(JMAppletViewerOld.jav a) at com.apple.mrj.JManager.JMViewerEvent.post(JMAppletViewerOld.java) at com.apple.mrj.JManager.AVDispatcherThread.run(JMAppletViewerOld.java)"
 
Zuletzt bearbeitet:

Neurodeamon

Erfahrenes Mitglied
Hast Du die Fehler auch mit anderen Browsern, z. B. mit Mozilla oder Opera?
Der IE für den Mac hat was Java angeht oft seltsame Fehlermeldungen. Bei mir schmiert der IE z. B. ab, wenn ich das MRJ Java aktiviere. Alle anderen Browser funktionieren dagegen einwandfrei - Problemlösung habe ich nicht mal über die Tech-Hotline von M$ bekommen.

Das ganze passierte bei mir, nachdem ich das MRJ aktualisiert hatte. Es scheint da einige Macken zu geben ... und da verfluchen alle Windows =)
Man hat da ja noch die Wahl Sun Java draufmachen zu können und nicht die VM von M$ benutzen zu müssen.

Der Fehler deutet aber IMHO auf einen Classpath Fehler hin. Könnte es sein, das das .jar nicht i. O. ist ?
 
Zuletzt bearbeitet:

qXp

Grünschnabel
mozilla & opera habe ich nicht, netscape hängt sich häufig auf - weiss absolut nicht an was das liegen könnte.
im IE treten die fehler immer dann auf, wenn applets und javascript im spiel sind.
 
Zuletzt bearbeitet:

Neurodeamon

Erfahrenes Mitglied
Die Fehlermeldung, die Du bekommst hört sich nach fehlerhaftem Java-Code an. Jedenfalls kenne ich des nur von Programmierfehlern (ich selbst Programmiere nicht Java, darf aber öfter Zeug von einem Freund testen :) )



NACHTRAG:

Ich habe gerade festgestellt, das mein seit über einem Jahr existierenden Problem keinen Bestand hat. Ich habe alle MRJ-Dateien die ich gefunden habe gelöscht (hähä, bei Windows wäre das nicht gegangen - da braucht man nen Deinstaller sonst muckt das System rum). Aber alle MRJ-Dateien in System- und MRJ Applikationsverzeichnissen.

Neu installiert und schon geht mein Java wieder mit IE & Co :) :) :)
Vielleicht solltest Du Dir auch überlegen, MRJ kicken und das "aktuelle" 2.2.5 für OS 9 draufspielen. Selbst wenn Du vorher auch schon 2.2.5 hattest, weg damit und neu drauf. Theoretisch dürfte Dein Fehler nun auch der Geschichte angehören. ;-)

Auf eigene Gefahr ! ;)
 
Zuletzt bearbeitet: