Dienst installieren


maendler53

Grünschnabel
Hallo zusammen,

Beim installeren eines eigenen Denstes mit InsallUtil.exe bekmme ich folgende Fehlermeldung:

C:\Windows\Microsoft.NET\Framework\v4.0.30319> InstallUtil.exe E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll
Microsoft (R) .NET Framework-Installationsprogramm, Version 4.6.1586.0
Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.


Eine transaktive Installation wird ausgeführt.

Die Installationsphase wird gestartet.
Die Protokolldatei enthält den Fortschritt der Assembly E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll.
Die Datei befindet sich in E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.InstallLog.
Assembly E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll wird installiert.
Betroffene Parameter:
logtoconsole =
logfile = E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.InstallLog
assemblypath = E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll
Keine öffentlichen Installer mit dem RunInstallerAttribute.Yes-Attribut in der Assembly E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll gefunden.

Die Installationsphase ist abgeschlossen, und die Commitphase beginnt.
Die Protokolldatei enthält den Fortschritt der Assembly E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll.
Die Datei befindet sich in E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.InstallLog.
Assembly E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll wird ausgeführt.
Betroffene Parameter:
logtoconsole =
logfile = E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.InstallLog
assemblypath = E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll
Keine öffentlichen Installer mit dem RunInstallerAttribute.Yes-Attribut in der Assembly E:\AGENDA_WIN_SRV\js.Agenda.WinSRV\bin\Debug\js.Agenda.Services.dll gefunden.
Die InstallState-Datei wird entfernt, da keine Installer vorhanden sind.

Die Commitphase wurde erfolgreich abgeschlossen.

Die transaktive Installation ist abgeschlossen.

Der Cde der Installerkasse:

[RunInstaller(true)]
public class MailSRVInstaller : Installer
{

public MailSRVInstaller()
{
ServiceInstaller installer = new ServiceInstaller();
ServiceProcessInstaller process = new ServiceProcessInstaller();

installer.StartType = ServiceStartMode.Automatic;
installer.ServiceName = "Jungfrau-Soft MailSRV";
installer.Description = "MailMessageService for AgendaV1";

process.Account = ServiceAccount.LocalSystem;

Installers.Add(process);
Installers.Add(installer);
}
}

Meines erachtens ist mit dem Atribut [RunIstaller(true)] und public class MailSRVInstaller : Installer, die Klasse öffentlich und sollte vom InstallUtil.exe erkannt werden.

Wo liegt nun der Fehler?

Gruss Alex
 

Neue Beiträge