Deform Bend auf Polygon - nach Bending Objekt frei bewegen / verändern

KillaBee

Mitglied
Hallo,

ich bin dabei mir eine gekrümmte Pipe zu bauen und habe dafür Deform > Bend angewendet, um die Kurve zu kriegen.
Wenn ich nun mein Objekt frei bewegen/rotieren will, verformt sich das ganze Objekt aber.
Kann man das Bending irgendwie abschließend auf das Objekt anwenden, so dass ich es danach frei transformieren und weiterverarbeiten kann?

Dankeschön :)
 

ArtificialPro

Pseudo Mitglied
Um das wieder zu ändern musst du shift+rmt drücken und dann auf Soften/harden Edges klicken, entweder alles soft oder das ganze mit einem Winkel definieren ;)
 

KillaBee

Mitglied
hmm, ich bekomme es trotzdem mit probieren verschiedener angles nicht hin, wenn ich die faces extrudiere und danach die edges markiere und den winkel for soften/harden verstelle.

ich habe mal mein modell hier hochgeladen.
vielleicht kannst du kurz ein blick reinwerfen? das wäre ganz lieb.

und dann suche ich gerade nach einer möglichkeit, nur die inneren flächen der pipe zu markieren, um nur dort eine textur anzuwenden. gibt es da eine funktion, diese zu selektieren?

http://www.cwt-international.com/forum/pipe.zip

vielen lieben dank für deine hilfe
 

ArtificialPro

Pseudo Mitglied
Also wenn ich deine Datei öffne sieht alles geglättet aus. Oder meinst du das Rohr in der Mitte?(Das NURBS-Objekt)

Um die Faces im inneren zu selektieren reicht das ganz normale Select Tool mit "Camera based selection" um keine dahinter liegenden Faces auszuwählen...

btw: Speicher lieber als *.ma, da ist die Wahrscheinlichkeit das Fehler entstehen geringer und man kann im Zweifelsfall die Datei selber umschreiben.

MfG
 

KillaBee

Mitglied
oh sorry, hatte dir eine ältere datei hochgeladen.
hier die aktuelle mit den eckigen flächen.
http://www.cwt-international.com/forum/pipe.zip

zum selektieren der inneren flächen der gekrümmten pipe:
um nicht die dahinter liegendesn faces zu markieren hab ich schon mit backfaceculling gearbeitet, aber da mein rohr ja über die ecke geht, seh ich ja die faces um die ecke herum nicht und markiere somit auch außerhalb welche.

ich dachte man könnte vielleicht eine fläche markieren und dann über Edit Polygons > Selection gehen, aber finde da nichts passendes.
wo ist denn das "camera based selected"? finde nicht, wo ich das einstellen kann. hab nur maya 7.0

vielen dank für deine hilfe
 

ArtificialPro

Pseudo Mitglied
Das Problem ist leicht. Du hast beim Extrudieren wohl ein paar Fehler gemacht.

Wenn du dir unter "Display/Polygons/Face Centers" die Mittelunkte der Polygone anzeigen lässt wirst du erkennen, dass zwischen jedem Polygon noch ein weiteres ist. Deshalb lässt sich das nicht glätten.

Lösche die Polygon einfach nochmal und mach den Extrude nocheinmal.

"Camera based selection" findest du in den Attributen des Move tools unter "Common Selection Options" Dort kannst du dann halt einstellen ob die Marquee Selektion durch Faces durchgehen kann.

Du kannst alternativ aber auch eine Loop Selektion machen und die Selektion mit "shift+>" vergrößern bis der Innenraum selektiert ist.

MfG
 

ArtificialPro

Pseudo Mitglied
Mhh, wenn er das schon beim Extrude macht, wüsste ich nur noch die Einstellungen zu resetten. Extrudierst du über das Menü oder per Drag über den Viewport? Vllt mal beides Versuchen.

Da fällt mir die dritte Möglichkeit ein, komisch das mir das jetzt erst einfällt..

Da die Form ja stimmt, bloß die Faces ja fast ineinander sind, kannst du auch die entsprechenden Vertices selektieren und dann "Merge Vertices" machen. Hab das gerade prbiert, geht nicht, weil die Faces von Letzten Stück 6lagig sind oder so, ka was du da angesellt hast :D

Also einfach löschen und versuchen es neu zu extrudieren^^
 

Neue Beiträge