1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

[Calc] Formel in eine bestimmte Zelle einfügen per Makro

Dieses Thema im Forum "Sonstige Sprachen" wurde erstellt von schmidtt1, 9. Juli 2014.

  1. schmidtt1

    schmidtt1 Mitglied

    Hallo,

    ich habe jetzt gesucht und ausprobiert.
    Jedesmal erscheinen irgendwelche Fehlermeldungen.

    Wie füge ich eine Formel in eine bestimmte Zelle ein per Makro?

    Freundliche Grüße
    Tobi
     
  2. ikosaeder

    ikosaeder Teekannen-Agnostiker

    Folgendes habe ich bei mir erfolgreich getestet:
    Code (Visual Basic):
    1. Sub Formel
    2. Dim Doc As Object
    3. Dim Sheet As Object
    4. Dim Cell As Object
    5. Doc = ThisComponent
    6. CurrentCell=Doc.Sheets(0).getCellByPosition(0,1)
    7. CurrentCell.setFormula("=sum(B2:B5)")
    8. End Sub

    Entscheidend ist hier die Verwendung der englischen Formel sum statt der deutschen Summe.

    Ansonsten wäre es schön, wenn du mehr Details posten würdest:
    • Welche Version du nutzt.
    • Welche Formel du einfügen möchtest.
    • Was du probiert hast.
    • Welche Fehlermeldungen du bekommst.
     
    schmidtt1 gefällt das.
  3. schmidtt1

    schmidtt1 Mitglied

    Hallo ikosaeder,

    das Problem hatte sich erledigt. Trotzdem danke.
     
  4. ikosaeder

    ikosaeder Teekannen-Agnostiker

    Lass die anderen an deinen Erkenntnissen teilhaben, wie hast du das Problem jetzt gelöst?
     
    schmidtt1 gefällt das.
  5. schmidtt1

    schmidtt1 Mitglied

    Code (Text):
    1. private sub FormelEinsetzen()
    2. oDocument = ThisComponent
    3. oSheet = oDocument.Sheets.getByIndex(0)
    4. mycell = osheet.getCellByPosition(8,1)
    5. mycell.Formulalocal = "=WENN(Q2="""";WENN(R2="""";WENN(S2="""";"""";S2);R2);Q2)"
    6. end sub
     
    ikosaeder gefällt das.
Die Seite wird geladen...