[Calc] Formel in eine bestimmte Zelle einfügen per Makro

schmidtt1

Mitglied
Hallo,

ich habe jetzt gesucht und ausprobiert.
Jedesmal erscheinen irgendwelche Fehlermeldungen.

Wie füge ich eine Formel in eine bestimmte Zelle ein per Makro?

Freundliche Grüße
Tobi
 

ikosaeder

Teekannen-Agnostiker
Folgendes habe ich bei mir erfolgreich getestet:
Visual Basic:
Sub Formel
Dim Doc As Object
Dim Sheet As Object
Dim Cell As Object
Doc = ThisComponent
CurrentCell=Doc.Sheets(0).getCellByPosition(0,1)
CurrentCell.setFormula("=sum(B2:B5)")
End Sub


Entscheidend ist hier die Verwendung der englischen Formel sum statt der deutschen Summe.

Ansonsten wäre es schön, wenn du mehr Details posten würdest:
  • Welche Version du nutzt.
  • Welche Formel du einfügen möchtest.
  • Was du probiert hast.
  • Welche Fehlermeldungen du bekommst.
 

schmidtt1

Mitglied
Code:
private sub FormelEinsetzen()
oDocument = ThisComponent
oSheet = oDocument.Sheets.getByIndex(0)
mycell = osheet.getCellByPosition(8,1)
mycell.Formulalocal = "=WENN(Q2="""";WENN(R2="""";WENN(S2="""";"""";S2);R2);Q2)"
end sub