Blender Cycles (GP)

MiMi

Erfahrenes Mitglied
Hi,

habe vor kurzem wieder mit Blender angefangen und in nem Tutorialvideo wurde gezeigt das man die ViewCamera Ansicht mit dem neuen Renderer auf "rendered" stellen kann und dafür in den Optionen auf GPU rendern statt CPU stellen muss, damit das ganze schneller geht.
Den Viewport habe ich auf "rendered" eingestellt, jedoch kann ich in den Optionen nicht auf GPU umstellen.
Habe jetzt mehrere Threads gelesen das das an der AMD Graka liegt, jedoch ist die Graka ziemlich neu und laut Treiber müsste auch das OpenCL mit drin sein.
Muss ich sonst noch was einstellen damit da funktioniert und ich auf GPU umstellen kann?
 

grotten

Schusselkopf
Hallo,

jetzt wäre erstmal die Frage, inwiefern du nicht auf GPU umstellen kannst? Steht bei dir in den Einstellungen unter Compute Device "None"? Dann wird die Grafikkarte scheinbar nicht unterstützt... oder steht da doch etwas aber du kannst dann aus irgendeinem Grund nicht umstellen?

Falls da "None" steht, könnte folgendes der Grund sein, siehe Blender Manual:

"The implementation of OpenCL is only in an experimental stage and disabled in official builds."

Kommt aber sicher auch immer darauf an, welche Version von Blender du überhaupt verwendest. Und dann kannst du natürlich in den Rendereinstellungen noch auswählen, ob du mit GPU rendern möchtest, Zitat:

"To enable GPU rendering, go into the User Preferences, and under System tab, select the Compute Device(s) to use. Next, for each scene you can configure to use CPU or GPU rendering in the Render properties."

Abgesehen davon, du kannst aber schon im Viewport auf "Rendered" stellen, oder nicht? Dir geht es nur darum mehr Geschwindigkeit zu bekommen? Dann ist auch immer die Frage ob es etwas bringt.

Ich zum Beispiel habe einen Rechner mit einer mittelmäßigen bis doch eher unterdurchschnittlichen Grafikkarte, weil das Hauptaugenmerk auf Rechenleistung liegt. Mein 8-Kern-Prozessor mit 16 GB RAM rechnet jedes Cycles-Bild zigmal schneller als meine Nvidia-GPU.

Von daher stellt sich auch die Frage, ob du wirklich was gewinnst wenn du auf GPU-Rendering umstellst... wobei die meisten ja ganz begeistert davon sind, wie schnell das sein soll. Ist also einen Versuch wert, vielleicht stimmen ja auch meine Einstellungen einfach nicht.
 

MiMi

Erfahrenes Mitglied
Hui so eine ausführliche Antwort :) danke erstmal

Meine Blender Version: 2.67b (laut splash screen beim starten)
Mein PC schaut wie folgt aus:
CPU: AMD FX-8320, 3725 MHz (8 Kern)
Radeon HD 7870 mit 2gb RAM
Arbeitsspeicher: 8GB (DDR3-1600)

Wie bereits erwähnt kann ich es nicht einstellen in den Optionen. Also die User preferences.
Also ja bei mir steht "none"

Ob es was bringt, wollte ich ausprobieren, daher die Frage, da im Video das Bild viel schneller gerendert wurde.

Den Satz in der Blender manual hab ich wohl gekonnt übersehen, hatte nur was von den Einstellungen gefunden wo man das macht und dann gegoogelt und was gelesen in nem Forum das es mit AMD Grakas nicht funktioniert. Und mich dann da auf die Suche versteift.

Dann wird wohl eher die Blender Version Schuld sein.
 

Neue Beiträge