Apache2 leitet Domain ohne ersichtlichen Grund auf default-vHost


Felix Kunsmann

Kurz weg …
Guten Morgen Community!

Ich hätte da ein kleines Problemchen mit meinen Apache2-Webserver. Seit heute morgen wird meine Blog-Domain felix-kunsmann.de nicht mehr auf meinen Blog geleitet, sondern auf den Default-VirtualHost.

Server version: Apache/2.2.9 (Debian)
Server built: Mar 28 2010 19:04:04

apache2ctl -S
Code:
VirtualHost configuration:
188.40.68.67:80        is a NameVirtualHost
         default server felix-kunsmann.de (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost felix-kunsmann.de (/etc/apache2/sites-enabled/000-default:1)
         port 80 namevhost christian-schubert.org (/etc/apache2/sites-enabled/christian-schubert.org:1)
         port 80 namevhost dump.mysqladmin.kunsmann.eu (/etc/apache2/sites-enabled/dump.mysqladmin.kunsmann.eu:1)
         port 80 namevhost felix-kunsmann.de (/etc/apache2/sites-enabled/felix-kunsmann.de:1)
         port 80 namevhost www.felix-kunsmann.de (/etc/apache2/sites-enabled/felix-kunsmann.de:25)
         port 80 namevhost galerie.kunsmann.eu (/etc/apache2/sites-enabled/galerie.kunsmann.eu:1)
         port 80 namevhost iamcharl.es (/etc/apache2/sites-enabled/iamcharl.es:1)
         port 80 namevhost mail.kunsmann.eu (/etc/apache2/sites-enabled/mail.kunsmann.eu:1)
         port 80 namevhost mysqladmin.kunsmann.eu (/etc/apache2/sites-enabled/mysqladmin.kunsmann.eu:1)
         port 80 namevhost piwik.kunsmann.eu (/etc/apache2/sites-enabled/piwik.kunsmann.eu:1)
         port 80 namevhost sbnc.kunsmann.eu (/etc/apache2/sites-enabled/sbnc.kunsmann.eu:1)
         port 80 namevhost srv.kunsmann.eu (/etc/apache2/sites-enabled/srv.kunsmann.eu:1)
         port 80 namevhost webalizer.kunsmann.eu (/etc/apache2/sites-enabled/webalizer.kunsmann.eu:1)
         port 80 namevhost webmail.kunsmann.eu (/etc/apache2/sites-enabled/webmail.kunsmann.eu:1)
Syntax OK

/etc/apache2/ports.conf
Code:
NameVirtualHost 188.40.68.67:80
Listen 188.40.68.67:80

<IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
</IfModule>

/etc/apache2/sites-enabled/000-default
Code:
<VirtualHost 188.40.68.67:80>
	ServerAdmin postmaster@kunsmann.eu

	DocumentRoot /var/www/default

	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/error/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

/etc/apache2/sites-enabled/felix-kunsmann.de
Code:
<VirtualHost 188.40.68.67:80>
	ServerName felix-kunsmann.de

	ServerAdmin felix@kunsmann.eu

	DocumentRoot /var/www/felix-kunsmann.de/www
	<Directory /var/www/felix-kunsmann.de/www/>
		Options FollowSymLinks

		AllowOverride All

		Order allow,deny
		allow from all
	</Directory>

	ErrorLog /var/www/felix-kunsmann.de/log/error.log
	CustomLog /var/www/felix-kunsmann.de/log/access.log combined

	php_admin_value open_basedir /var/www/felix-kunsmann.de/www/:/var/www/felix-kunsmann.de/tmp/
	php_admin_value session.save_path /var/www/felix-kunsmann.de/tmp/
	php_admin_value upload_tmp_dir /var/www/felix-kunsmann.de/tmp/
	php_admin_value error_log /var/www/felix-kunsmann.de/log/php-error.log
</VirtualHost>

<VirtualHost 188.40.68.67:80>
	ServerName www.felix-kunsmann.de
	ServerAlias *.felix-kunsmann.de

	RedirectPermanent / http://felix-kunsmann.de/
</VirtualHost>

Wo ist hier der Fehler und wie kann ich ihn beheben?

PROBLEM GELÖST: In den default-vHost muss wohl auch ein ServerName, sobald der reverse DNS des Servers mit einem VirtualHost übereinstimmt.
 
Zuletzt bearbeitet: