Anzeige Seriendruckfeld & Wenn Dann Funktion

Nospherates

Erfahrenes Mitglied
Hallo zusammen!
Ich versuche einen eigentlich recht simplen Serienbrief zu erstellen, stolper jedoch über eine vermeintliche Kleinigkeit.
Der Brief soll sowohl an deutsche als auch ausländische Adressaten gehen. In der Datenquelle, einer Exceltabelle, ist das Feld PLZ nur bei den deutschen Empfängern gefüllt, bei den ausländischen ist die PLZ mit im Ort-Feld.

Bei den deutschen funktioniert das soweit auch alles wunderbar, nur bei den Ausländern wird statt nichts, eine 0 vor dem Ort angezeigt. Ich habe daraufhin in Excel sicherheitshalber alle Inhalte gelöscht in den entsprechenden Zellen und die Zelle als Text deklariert, ohne Erfolg. Danach habe ich versucht das ganze über eine "Wenn...dann..sonst" Funktion abzuwickeln, was aber daran scheiterte, dass ich keine Felder in die Funkton einbauen kann. Ich hab über Google zwar diverse Beispiele gesehen, aber die funktionieren hier irgendwie nicht. Statt dem Feldinhalt bekomme ich immer nur "Mergefield" angezeigt oder ähnliches.

Die Funktion sieht folgendermaßen aus:

{ if { Mergefield "PLZ" } = "" "" "{ Mergefield "PLZ" }}

Bevor der Ratschlag kommt, ich hab vermutlich alle möglichen Variationen ausprobiert, vonwegen Anführungszeichen weglassen, Leerzeichen weglassen, Groß-/Kleinschreibung etc.. alles ohne Erfolg.

Ich vermute/hoffe, dass einfach nur irgendwas falsch eingestellt ist, damit es funktioniert, aber ich hab mittlerweile keine Ahnung mehr wo ich gucken soll. Hoffe da hat jemand einen Tipp oder gar eine Lösung für mich?!

Danke fürs lesen!

PS: Hier ist Windows XP im Einsatz und Office 2002. 2000 und 2003 stehen ebenfalls zur Verfügung, da hab ich aber die selben Ergebnisse -.-
 

Zvoni

Erfahrenes Mitglied
Ich erinner mich dunkel daran, dass es bei den Seriebriefen eine Option gibt "Leeres Feld unterdrücken" oder so etwas. Weiss es nicht mehr genau.
 

Nospherates

Erfahrenes Mitglied
Ja, das hab ich auch schon irgendwo gelesen, bezog sich da aber wohl auf Word 2000, ich hab dazu jetzt nichts gefunden.

Als nicht gerade elegante, aber funktionierende Lösung hab ich die Excel Tabelle nun in eine csv Datei umgewandelt, da hat das dann auch funktioniert. Scheint also irgendwie doch an der Exceldatei zu liegen, aber ich sehe da keine Möglichkeit noch was entsprechend umzustellen.

Wenn noch jemand eine bessere Lösung hat würd ich die aber liebend gerne nehmen :)
 

Zvoni

Erfahrenes Mitglied
Ahhh, mir ist eine Idee gekommen, woran es liegen kann.

Hast du das PLZ-Feld selbst erstellt, oder hast du es automatisch vom Assi erstellen lassen?

Weil wenn automatisch, dann ist es klar: in Deutschland ist die PLZ numerisch, und dann bekommst du für leeres Feld eine 0 heraus

EDIT: Mein Post ist Quatsch! Sorry, aber mein Arbeitskollege hat mich gerade tierisch genervt!
Da es in Deuutschland PLZ's mit führender 0 gibt (Ost-Deutschland) ist die PLZ Alphanumerisch, also Text. Ergo, woher die 0 dann kommt, weiss ich dann auch nicht.