Android Emulator lädt Veränderungen aus Klassen nicht

Bexx

Verrückte Erfinderin bei Daniel Düsentrieb
Hi Foris,

dickes Problem. Habe anfänglich ein kleines Demoprojekt begonnen in denen ich die Funktionalität unter Android von dem was ich machen will ein bisschen getestet habe.

Dann habe ich von extern einige Source-Klassen in meinen Eclipse (Indigo) Workspace gezogen, in Eclipse mein Package aktualisiert und tadaa, sie waren da.
Dann das Projekt von Test123 in etwas seriöses umbenannt mit 'Refactor' und puff fliegt mir der Emulator um die Ohren. Das Schiere an der Geschichte: in der Fehlermeldung steht immer noch Test123Activity konnte nicht geladen werden oder stopped unexpectedly...

Ich hab bereits den Emulator gelöscht, neu erstellt. Dann wieder und wieder sogar mit nem neuen Target! Aber iwie kriegt er's nicht geschissen, die Änderungen zu akzeptieren und jetzt liegt das ganze Projekt brach...

In mir macht sich so ne kleine Panikattacke breit, kann mir jemand helfen?
 

genodeftest

Erfahrenes Mitglied
Da gibts irgend einen Eclipse Bug, der dazu führt, dass Eclipse deinen Quellcode einfach nicht mehr compiliert. Dieser Bug tritt nur ganz selten unter ungewöhnlichen Umständen auf. Probier mal folgendes:
- Eclipse neu starten
wenn das nichts hilft:
- im Workspace die Dateien und Ordner mit . vorne dran (.project, .settings, .classpath) löschen (nach einer Sicherung natürlich!), aus deinem Workspace raus ziehen (verschieben) und dann das Projekt einfach neu erstellen und die Daten (Quellcode) wieder hinein kopieren.
 

Bexx

Verrückte Erfinderin bei Daniel Düsentrieb
die .settings datei gibts in meinem projekt gar nicht und einen ordner der so heißt auch nicht...
schätze das gehört iwie zu meinem problem.. :(
 

Bexx

Verrückte Erfinderin bei Daniel Düsentrieb
nee also ohne die dateien will er mir mein projekt nicht mehr öffnen :/
 
S

SE

Ähm ... könnte es auch vielleicht sein das NetBeans den Fehler gemacht hat und nur die logische Anzeige nicht aber die physischen Files geändert hat ? Vielleicht solltest du mal NetBeans beenden und dann im WorkSpace mit nem Editor reinsehen ob die Java-Files auch wirklich 1) so heißen wie sie sollen und 2) auch das drin steht was drin stehen müsste *also richtige package-Pfade , Klassenname*.
 

inter

Mitglied
Hast Du den Namen der Activity in der Manifest.xml angepasst? Kann mir gut vorstellen, dass der das beim Refactoring nicht automatisch macht. Die Fehlermeldung wüde dazu passen...
 

Neue Beiträge