Anzeige

Systemzeit läuft viel zu schnell


Adi | tmine

Erfahrenes Mitglied
#1
Hi zusammen
Ich bin jetzt nicht sicher wo ich das Thema hin tun soll. Windows oder VmWare ...

Ich versuche es einfach mal hier =)

Also ich habe folgendes Problem:

Ausgangslage:
Auf meinem Windows Server 2003 läuft eine VmWare auch mit einem Windows Server 2003. Auf der Vm befindet sich mein Webserver.

Problem:
In der Vmware läuft die Systemzeit um einiges schneller als normal. Dies führt zu Problemen mit meinem Webserver.
Das komische ist, dass die Zeit auf dem Host normal und nur in der Vm schneller läuft.
Ich habe immer gedacht, dass die Systemzeit von der Hardware her gelesen wird?... ist das Bei Vmware anders? woher bekommt die VM die Systemzeit?


Weiss da einer Rat?
 
#2
Bin der Meinung ich hätt letztens noch iwas in der Richtung gehört, bin mir aber nicht mehr ganz sicher. Wenn die Folgende Aussage totaler Blödsinn ist, bitte korrigieren.

Ich glaube das liegt daran, dass deine CPU sich herunter taktet wenn sie nicht ausgelastet ist.
Dein locales System bekommt das natürlich mit und das "weiterzählen der Sekunden" wird der Taktfrequenz angepasst. Deine VM bekommt hingegen von dem heruntertakten nix mit und "rennt" los.
Ich glaube es gibt irgendwo eine Option wo man einstellen kann, das die VM sich regelmäßig mit der Systemzeit des localen Computer synchronisiert.
 

Adi | tmine

Erfahrenes Mitglied
#3
Danke für dein Antwort.
Genau auf diese Aussage bin ich vor ca. 2 Minuten bei Google gestossen =)
Nur leider hilft mir das nicht wirklich weiter, denn ich möchte die Systemzeit nicht ungenau haben. Ich brauche die Exakte Zeit !

Ich habe noch etwas weiter gelesen und herausgefunden, dass anscheinend nur bei AMD Prozessoren dieses Problem auftritt. Hat etwas mit dieser Cool 'n' Quiet Funktion zu tun. Abhilfe ohne Performanceverlust soll anscheinend nur das deaktivieren dieser Funktion schaffen.

Naja ich werde noch etwas weiter nachforschen.
Falls sich nochjemand damit auskennt oder ähnliche Probleme hat bin ich natürlich über Hilfe imemr dankbar =)
 
#4
Die Frage ist wie ungenau die Systemzeit wird, wenn sie sich stäntig mit der localen Zeit synchronisiert. Evtl geht sie dadruch ja so genau, dass es garnicht weiter auffällt, hast du es mal ausprobiert?
 

Adi | tmine

Erfahrenes Mitglied
#5
Ich habe mal bei VmWare Tools eingestellt, dass die Zeit automatisch mit der des Hosts abgeglichen werden soll. Dies hat aber bis jetzt noch gar nicht gebracht. Ev. kann ich per Batch job etwas erreichen. Habe aber leider im Moment keine Möglichkeit einen Batch auf dem Server laufen zu lassen. Werde dies aber noch testen.

Die dauernde Zeitsynchronisation könnte aber auch zu einer Performanceeinbusse führen.
 

Adi | tmine

Erfahrenes Mitglied
#7
Hört sich interessant an, hat aber leider bei mir nichts gebracht.
Werde wohl, wenn ich wieder zuhause bin die cool'n'Quiet Funktion mal deaktivieren und testen, ob die Zeit dann wieder normal läuft ...


EDIT:
Ich habe mir mal die Bootparameter von Windows angeschaut. Aber nichts gefunden, was helfen könnte ....

Nur einen Parameter namens: /TIMERES
Leider verstehe ich die Beschreibung nicht wirklich =( (http://www.winfaq.de/faq_html/Content/tip0000/onlinefaq.php?h=tip0408.htm)
 
Zuletzt bearbeitet:
Anzeige

Neue Beiträge

Anzeige