Sverweis mit 2 Kriterien

jerry0110

Erfahrenes Mitglied
Hallo zusammen,

ich habe eine Frage. Ich möchte einen Sverweis erstellen, welche sich auf 2 Tabellenblätter bezieht.
Dazu habe ich eine Hilfstabelle mit Namen in A1-A5 und in B1-B5 habe ich die Tabellenblätter geschrieben.

Code:
=SVERWEIS($B$24;SVERWEIS(Dashboard!$B$9;Hilfstabelle!A1:C10;3;FALSCH);2;FALSCH)

Im Grunde soll er im Dashboard nach dem Namen suchen und wenn er ihn gefunden hat im Tabellenblatt des Namen in die Tabelle gehen und den Wert in der Tabelle suchen.

Hier mal die Hilfstabelle:
A / B / C
1. Name A / 230JLA / Auswertung 230JLA'!$M:$T
2. Name B 230NSC / Auswertung 230NSC'!$M:$T
3. Name C 230SST / Auswertung 230SST'!$M:$T
4. Name D 230SBO / Auswertung 230SBO'!$M:$T
5. Team Team Auswertung Team'!$M:$T

Im Dashboard habe ich dann folgende Felder:

B9 = Name der gesucht wird
C9 = Datum

Wie man in der Hilfstabelle sieht, soll er, wenn Name A im Dashboard B9 steht, den Inhalt aus Zeile C nehmen, damit die Formel weiß, dass es sich im Tabellenblatt "Auswertung 230JLA'!$M:$T" befindet.
 
Zuletzt bearbeitet:

jerry0110

Erfahrenes Mitglied
Nach langem hin und her habe ich es dann doch hinbekommen.

Code:
=SVERWEIS(B24;INDIREKT("'"&SVERWEIS($B$9;Hilfstabelle!$A$1:$C$10;3;FALSCH));2;FALSCH)
 

Neue Beiträge