smoothing macht probleme....

hackler

Mitglied
hallo leute,
schön langsam wirds mir peinlich, aber eine frage hätt ich noch... :rolleyes:
eigentlich trau ich mich fast nicht meine frage zu stellen - schaut eigentlich sonnenklar aus die sache. ich kriegs aber irgendwie trotzdem nicht hin. :confused:
habe versucht, das problem möglichst eng einzukreisen und eine entsprechende datei beigefügt. ich habe eine vollkommen glatte wand, die an der ausnehmung leicht gerundete kanten hat (teil eines imports aus einem dwg). die geometrie ist sauber, keine doppelten punkte oder sonstwas, die flächen haben alle die selbe id und smoothinggroup.
d.h. eigentlich hätte ich jetzt gern eine glatte wand, die in eine glatte rundung übergeht, wäre ja eigentlich auch logisch, oder? wegen der rundung habe ich aber einige schattenlinien in der fläche, die da nichts zu suchen haben. entferne ich die rundungen, sind auch die schatten weg.
hat einer von euch eine ahnung, was da das problem ist? die sache ist unheimlich lästig, wenn man gerundete ecken machen will. plötzlich hat man die seltsamsten muster in den glatten flächen...
vielen dank schon mal!
hackler
 

Anhänge

  • smoothing.jpg
    smoothing.jpg
    33 KB · Aufrufe: 35
  • smooth.zip
    15,5 KB · Aufrufe: 10

grosserboss

Erfahrenes Mitglied
Versuch doch mal den Auto Smooth runter zu stellen.
Und wenn das auch nicht geht mach ein neues Face, also eine neue Fäche.
 

Anhänge

  • Autosmoth.jpg
    Autosmoth.jpg
    24 KB · Aufrufe: 31

cycovery

Erfahrenes Mitglied
Die vertexnormalen werden linear über die triangel interpoliert. Wenn du also vertexnormalen am rand deiner flachen wand hast, welche nicht normal zur wand stehen, wirst du ein solches shading bekommen. Du musst am rand, bevor die abgerundeten polygone anfangen, noch eine zusätzliche (dünne) reihe von polygonen einfügen, welche komplett auf der gleichen Ebene wie die grossen liegen. Dadurch kriegst du am Rand der Grossen polygone vertexnormalen die normal zur Wand stehen.
 

hackler

Mitglied
au verdammt!
ich habs befürchtet... habs bis jetzt auch mit der zusätzlichen netzteilung gemacht, was bei größeren modellen eine wirklich lästige arbeit ist. hätte gedacht, daß es da vielleicht einen besseren weg gibt, aber leider schauts ja nicht so aus.
bei mir tritt das problem dummerweise recht häufig auf -- scheinbar gibts bei mir zu viele abgerundete kanten.
vielen dank jedenfalls für die info - ist jetzt (leider) eine klare sache.

an grosserboss: so leicht gehts leider nicht, wenn ich das autosmooth so weit runterstell, daß die schatten weg sind, ist leider aus der rundung eine kante geworden.