1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Session-Problem bei Strato seit 4 Tagen

Dieses Thema im Forum "PHP" wurde erstellt von Hattrix, 9. Februar 2008.

  1. Hattrix

    Hattrix Erfahrenes Mitglied

    Hallo,

    hat jemand von euch auch Probleme mit Session mit Strato seit dem 5.2.2008?

    Ich habe an meinen Scripten nichts geändert und habe Problem mit Sessions. Sprich, die Sessions werden falsch bestückt, als würde ein request stattfinden. Bei meinem Captcha kommen falsche Werte heraus und mein Login funktioniert auch nicht mehr, sprich man wird zufällig ausgeloggt. Nur bei diesen beiden Sachen nutze ich Sessions und fällt mir deswegen auf. Beide Dinge treten nicht immer auf, sondern geschehen aus reinem Zufall, ich nenn's in den letzten Tagen immer "Lotterie". Auch habe ich in letzter Zeit enorme Probleme meine MySQL Datenbank zu pflegen, weil es wegen abgelaufener Session mich ausloggt!

    Wie gesagt, die Scripte funktionieren seit vielen Monaten und habe nichts an den Scripten oder im Admin-menü Versionen hichgeschraubt. Nichts.

    Daher hier meine Frage, ob jemand das gleiche Problem hat und wenn ja, was er dagegen gemacht hat? Weil der Support sich nicht meldet!

    Denn auf einen für mich gerade "Ersatz-Server" läuft alles ohne Probleme.
     
    Zuletzt bearbeitet: 9. Februar 2008
  2. Gumbo

    Gumbo Erfahrenes Mitglied

    Prüfe mal die Sitzungseinstellungen (ini_get_all()-Funktion), vielleicht wurden sie ungünstig geändert. Auch wäre es interessant zu erfahren, wie die Sitzungs-ID übermittelt wird und ob die Wiederaufnahme existierender Sitzungen einwandfrei funktioniert.
     
  3. Hattrix

    Hattrix Erfahrenes Mitglied

    Die Funktion "ini_get_all" sieht man hier das Ergebnis: http://www.hattrix-online.de/test.php Sagt mir jetzt aber alles überhaupt nichts!

    Genauso wenig, was du mit Session-ID und "Wiederaufnahme existierender Sitzungen einwandfrei funktioniert" meinst.

    Ich starte halt die Session mit "session_start();" und übergebe Variablen den Sessions:
    $_SESSION['name']=$name;
    ...
     
  4. Flex

    Flex (aka Felix Jacobi)

    Veränder die Ausgabe bitte mal so:

    Code (PHP):
    1. <?php
    2. echo '<pre>'.print_r(ini_get_all(), true).'</pre>';
    3. ?>
     
  5. Gumbo

    Gumbo Erfahrenes Mitglied

    Es reicht der für Sitzungen relevante Bereich (ini_get_all('session')).

    Tritt dieses Verhalten eigentlich bei jedem Browser auf oder ist es nur auf einige beschränkt?
     
  6. Hattrix

    Hattrix Erfahrenes Mitglied

    Darstellung wurde geändert.

    Nur bei Firefox, IE und Opera getestet. Bei allen dreien ist das der Fall!
     
  7. Flex

    Flex (aka Felix Jacobi)

    Was ich spontan sehe:

    Ist nicht gerade gut, dieses Feature aktiviert zu haben. Zumindest wenn man es nicht unbedingt braucht.

    Der Rest ist standardmäßig ok.
    Wurde in letzter Zeit bei Strato irgendetwas umgestellt?
    Hast du beim Support einmal angefragt?
     
  8. Loveboat

    Loveboat Erfahrenes Mitglied

    ...bin auch bei Strato und habe keine Probleme mit meinen Sessions, die laufen wunderbar...., hab nur andere Probleme :)

    Gruß
    Loveboat
     
  9. Hattrix

    Hattrix Erfahrenes Mitglied

    Ich weiß nix davon, dass Strato was umgestellt hat, zumindestens ist mir nichts bekannt. Und auch diese Einstellungen kann ich nicht ändern, da bei Strato man keine php.ini oder .htaccess einbinden kann - aus Sicherheitsgründen nicht! Das läuft alles über den Support!
     
  10. Flex

    Flex (aka Felix Jacobi)

    Wozu gibt es die Support Hotline?
    Die hat mir bei Strato immer geholfen... Sowohl bei einem Rootserver als auch bei einem Webspace Premium Paket.
     
  11. sim4000

    sim4000 Mitglied

    Ich hab / hatte das Problem auch seit ein paar Tagen bei dem Webspace eines Kunden.
    Man konnte sich nicht mehr im ACP anmelden, da das Cookie schon nach ein paar Sekunden verfiel.
    Das ist seit heute nicht mehr der Fall.
    Jetzt scheint es wieder wunderbar zu laufen. :)

    Ne Mail an den Support hab ich auch geschrieben. Hab aber bisher keine Antwort bekommen.
     
  12. Hattrix

    Hattrix Erfahrenes Mitglied

    Hab's daraufhin jetzt nochmal getestet, bei mir ist das Problem nicht weg!

    Support-Hotline ok, wird aber ein teures Telefonat! :(
     
  13. sim4000

    sim4000 Mitglied

    Schick denen über das Kontaktformular ne Mail.
    Dauert zwar länger, kostet aber nix.
     
  14. Hattrix

    Hattrix Erfahrenes Mitglied

    Mein Eingangsbeitrag scheint man sich nur zur Hälfte durchzulesen, weil da steht, dass ich mich bereits beim Support gemeldet haben. ;) *g*

    2 Mails seit 5.2. -> keine Antwort

    Heute gegen 10 Uhr angerufen, da war kein Techniker am Platz ... es wird sich heute drum gekümmert und man wird sich bei mir melden! Bisher wurde nichts getan!
     
  15. sim4000

    sim4000 Mitglied

    Ups. Das hab ich wohl überlesen. Sry.
    Tja, und dabei soll Strato eigentlich n guten Support haben...
     
  16. Hattrix

    Hattrix Erfahrenes Mitglied

    Oh, heute schrieb mir Strato. Man hat die PHP Version von 4.4.7 auf 4.4.8 gestellt. Aber das macht doch die Session-geschichte nicht gleich "Nicht-Funktionsfähig"?
     
  17. sim4000

    sim4000 Mitglied

    Nö. Eigentlich nicht.
    Ich habe schon viele Apache-Server aufgesetzt. Und damit hatte ich noch nie Probleme.

    Außer die backen selber.
    Dann kann das schon sein.
     
  18. michael0129

    michael0129 Grünschnabel

    Hallo,
    habe dieses Problem auch, aufgefallen letzte Woche Donnerstag :confused:. Vorher lief das ganze auch ohne Probleme. Habe Strato ebenfalls angeschrieben und hoffe auf eine etwas hilfreichere Antwort. Wenn allerdings jemand eine Lösung hat bin ich natürlich sehr dankbar.:)

    Gruß
    Michael
     
  19. Yoel

    Yoel Grünschnabel

    Ich bin zwar subjektiv betroffen, aber ich kann euch nur dazu raten, ein paar andere Anbieter zu vergleichen. Ich hatte mit Strato 3 Monate wegen den Sessions rumgezackert ohne Erfolg. Bei mir trat der Server Internal Error 500 SPORADISCH auf bei einem SIMPLEN zweizeiligen Script <?php session_start(); echo session_id(); ?>. Ich war zudem unglücklich über lange Ladezeiten. Bei anderen Anbietern stelle ich dieses Problem keinesfalls fest.

    Vergleicht einfach euren Quellcode bei anderen Anbietern.
    Schließlich leben wir in Zeiten freier Marktwirtschaft.

    Man kann natürlich vermuten, dass das Problem bei Strato liegt, aber mehr auch nicht.
     
  20. FabsNo1

    FabsNo1 Grünschnabel

    Wir haben auf unserer Seite exakt das gleiche Problem seit ein paar Tagen,... Immer wieder was Neues mit Strato,....
     
Die Seite wird geladen...
Ähnliche Themen - Session Problem Strato
  1. Alice
    Antworten:
    3
    Aufrufe:
    340
  2. magicmarkus
    Antworten:
    0
    Aufrufe:
    446
  3. donpaolo
    Antworten:
    8
    Aufrufe:
    1.338
  4. xtramen01
    Antworten:
    6
    Aufrufe:
    1.088
  5. Divo1984
    Antworten:
    1
    Aufrufe:
    463