PSPad-Textanzeige nur im HEX-Monitor ****

vfl_freak

Premium-User
Moin,

habe leider kein passenderes Unterforum gefunden ...

Wir nutzen hier in der Firma PSPad zum Editieren einfacher Textdateien (Configs, einfache Dokus etc. - allesamt auch mit PSPad erzeugt).

Ich habe nur schon seit einiger Zeit das Problem, dass manche Dateien nur in der Hex-Anzeige geöffnet werden. Ich kann dann diesem Modus auch nicht über das Menü "Anzeige" umschalten, da der Menüpunkt "Hexadecimale Anzeige" ausgegraut ist und somit nicht zur Verfügung steht ....
Habe schon sämtliche Einstellungen durchforstet, ebenso das Programm deinstalliert und dann die aktuelle Version V4.5.7 (2450) installiert - aber keine Änderung.

Ebenso wenig sind die Extensions bekannter Datentypen ausgeblendet, so dass ich sicher sein kann, dass es wirklich txt-Dateien sind.

Ich hoffe, dass irgendwer hierzu eine Idee oder Hinweis hat!

Danke und Gruß
Klaus
 

ikosaeder

Teekannen-Agnostiker
Mal in einem anderen Editor ausprobiert, ob, warum auch immer irgendwelche Steuerzeichen enthalten sind so das sie als Binär interpretiert werden? Hat der Editor vielleicht bestimmte Datentypen, die im Hexmodus geöffnet werden?
 
Zuletzt bearbeitet:

vfl_freak

Premium-User
Moin,

Mal in einem anderen Editor ausprobiert, ob, warum auch immer irgendwelche Steuerzeichen enthalten sind so das sie als Binär interpretiert werden?
nein, außer dem "Standard"-WinEditor noch nicht - nun dürfen wir hier auf den Firmenrechnern aber auch nicht so einfach Fremd-SW installieren.
Zudem sollte ich solche Zeichen doch gerade im hex-Editor sehen können ....
Die Texte, umdie es hier geht sind selten länger als eine DIN A4-Seite!

Hat der Editor vielleicht bestimmte Datentypen, die im Hexmodus geöffnet werden?
Nicht dass ich wüßte. Mit manchen txt-Files geht es dann ja auch .... was natürlich den Verdacht audf andere Steuerzeichen nahe legt.
Mal schauen, ob ich mir was anderes installieren darf!

Danke und Gruß
Klaus
 

ikosaeder

Teekannen-Agnostiker
Wenn Notepad die Dateien als Txt öffnet, dann speicher sie einfach mal damit ab in lad sie danach in pspad.
 

vfl_freak

Premium-User
Moin,

nein, dass ändert leider auch nichts!

Man sieht auch vor und nach dem Speichern oben links im Reiter mit dem Dateinamen ein kleines blaues Kästchen, dessen Bedeutung ich allerdings nicht kenne ....

Wenn ich eine Textdatei lade, die normal dargestellt wird, ist dieses Kästchen nicht sichtbar und auch beim lustigen hin- und herschalten in Hex-Ansicht und wieder zurück erscheint es nicht !

Gruß
Klaus

BTW: habe es eben noch mal mit WordPad versucht - auch da werden die Dokumente korrekt dargestellt (allerdings kennt das auch wohl keinen HEX-Modus)
 
Zuletzt bearbeitet:

ikosaeder

Teekannen-Agnostiker
Aus dem PsPad forum:
PSpad automatically detect non-text chars in text and open such file in HEX editor to prevent damage of binary file content.
You can switch detection off. Go to program settings, press direct edit button and change value of:
AutodetectBinary=0
http://forum.pspad.com/read.php?2,59459,59460#msg-59460

Das bedeutet aber, das du tatsächlich irgendwelche Steuerzeichen in der Datei hast. Hast du die Datein mal per FTP kopiert, oder in Word o.ä. geöffnet?
 
Zuletzt bearbeitet:

vfl_freak

Premium-User
Moin,

oh, das klingt interessant - habe ich dort gestern leider nicht gefunden (oder iwie überlesen).

Und ja, in den betroffenen Texten können auch nicht darstellbare Zeichen stehen, da hiermit u. a. Commando-Buffer beschrieben werden!

Dann werde ich das mal suchen ...

Danke und Gruß
Klaus

[EDIT]
Jau, genau das war es :) und für alle, die wie ich die deutsche Version nutzen :
unter "Einstellungen" / "Programm einstellen" unten auf den Button "[Special Settings]" klicken !
 
Zuletzt bearbeitet: