Probleme mit neuer JAVA-Version

xrax

Erfahrenes Mitglied
Hallo zusammen,

ich habe bisher Java 1.6 mit Eclipse genutzt.
Diese Java-Version habe ich auch auf dem Server auf welchem meine Programme laufen.

Jetzt habe ich auf meinem lokalen Rechner die neuste Javaversion installiert und die alte deinstalliert.
Als erstes lief mein Eclipse nicht mehr. Das habe ich mit einer Änderung der Variablem auf die neue Version gefixt. Allerdings sind meine Eclipse-Projekte nun alle mit einem roten Asrufezeichen markiert.
Ich könnte nun jedem Projekt die neue Javaversion zuweisen. Es hat sich aber gezeigt das es Befehle gibt, die wieder rot markiert werden.
Muss ich nun alle Projekte durchgehen und Lösungen finden ?
zB für "The type java.lang.CharSequence cannot be resolved. It is indirectly referenced from required .class files"
Und,- dann läufts nur wenn ich auch diese Java-Version auf den Server lege und die "alte" deinstalliere ?

Wie gehe ich am besten vor ?

Besten Dank
xrax