Problem Seafile.conf von Nginx auf Serversystem einrichten

Jan-Frederik Stieler

Monsterator
Moderator
Hi,
ich habe ein Raspberry pi mit Nginx bei mir stehen welcher über ein dynamic DNS angesprochen wird.
nun habe ich bei meine mProvider subdomains eingerichtet welche per CNAME auf diese dynamic DNS gemapt werden und auf einen entsprechenden Unterordner geleitet werden.

Nun habe ich das Problem das ich Seafile auf dem Raspberry pi installiert habe und es nicht gebacken bekomme die conf dafür so einzurichten das diese mit dem System auch funktioniert.

Meine default.conf:

Code:
server {
    listen 80;
    listen [::]:80;

    listen 443 ssl;
    listen [::]:443 ssl;

    ssl_certificate /etc/letsencrypt/live/cloud.kdjfs.de/fullchain.pem;
    ssl_certificate_key /etc/letsencrypt/live/cloud.kdjfs.de/privkey.pem;
    ssl_trusted_certificate /etc/letsencrypt/live/cloud.kdjfs.de/chain.pem;

    server_name ~^(?<sub>.+)\.kdjfs\.de$;

    root /var/www/html/$sub;

    index index.html index.htm index.php index.nginx-debian.html;

    add_header X-Robots-Tag "noindex, nofollow" always;

    location / {
        try_files $uri $uri/ =404;
    }

    location ~ \.php$ {
        include snippets/fastcgi-php.conf;
        fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
    }

    location /webdav {
        dav_methods PUT DELETE MKCOL COPY MOVE;
        dav_ext_methods PROPFIND OPTIONS;
        dav_access user:rw group:rw all:rw;

        autoindex on;

        #client_body_temp_path /tmp/nginx/client-bodies;
        client_max_body_size 0;
        #create_full_put_path on;

        auth_basic "restricted";
        auth_basic_user_file /var/www/html/webdav/.htpasswd;
    }
}
server {
    listen 80;
    listen [::]:80;

    server_name  ~^(?<sub>.+)\.kdjfs\.de$;
    return 301 http://$host$uri;
}

hier die seafile.conf:

Code:
server {
    listen 80;
    server_name _;

    proxy_set_header X-Forwarded-For $remote_addr;

    location / {
         proxy_pass         http://127.0.0.1:8000;
         proxy_set_header   Host $host;
         proxy_set_header   X-Real-IP $remote_addr;
         proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;
         proxy_set_header   X-Forwarded-Host $server_name;
         proxy_read_timeout  1200s;

         client_max_body_size 0;

         access_log      /var/log/nginx/seahub.access.log;
         error_log       /var/log/nginx/seahub.error.log;
    }
    
    location /seafhttp {
        rewrite ^/seafhttp(.*)$ $1 break;
        proxy_pass http://127.0.0.1:8082;
        client_max_body_size 0;
        proxy_set_header   X-Forwarded-For $proxy_add_x_forwarded_for;

        proxy_connect_timeout  36000s;
        proxy_read_timeout  36000s;
        proxy_send_timeout  36000s;

        send_timeout  36000s;

        access_log      /var/log/nginx/seafhttp.access.log;
        error_log       /var/log/nginx/seafhttp.error.log;
    }

    location /media {
        root /home/seafile/seafile-server-latest/seahub;
    }
}