kvm / qemu Tastatur geht nicht =>falsch belegt

Holger5

Grünschnabel
Hi,
ich mache gerade die ersten Versuche mit kvm. Nach diversen Schwierigkeiten hänge ich jetzt an dem Problem das im Gast-Rechner die Tastatur nicht richtig funktioniert. Bei drücken der Taste s kommt b, bei q kommt c, bei t kommt n, bei Shift(Umschalt) kommt 1 und so weiter. Leider sind nicht alle Zeichen vorhanden. Getestet habe ich Windows2000 Installation(bis zur Seriennummer-Eingabe) und MS-Dos6.

Das Problem tritt direkt am Rechner auf und auch mit tightvncserver.

Vielen Dank.
Holger
 

Sinac

Erfahrenes Mitglied
Hm, das klingt sehr merkwürdig. Führst du die VMs als Root aus? Was für ein Hostsystem läuft drunter?
 

Holger5

Grünschnabel
System: Gigabyte GA-MA69VM-S2, AMD X2-6000+, 8GB Ram; 160GB HD; Debian 2.6.22-2-amd64; QEMU PC emulator version 0.9.0

Ich hatte kvm von der Konsole (als root) gestartet und diese Probleme bekommen und daruafhin X11 und vnc installiert und von einen Anderen PC per VNC gestartet. Egal wo ich kvm starte immer die gleichen falschen tasten. Auf der Oberfläche sieht alles normal aus und die Tastatur funktioniert einwandfrei...

Da KVM für die externen Monitorumschalter verwendet wird, ist das googlen sehr mühsahm und nach 3 Stunden hab ich aufgegeben :mad:
 

Sinac

Erfahrenes Mitglied
Das stimmt, suchen nach KVM ist immer ein wenig doof ;)

Passiert das Ganze nur unter kvm oder auch unter qemu nativ? Probier mal mit "qemu -k de" das Tastaturlayout zu übergeben.
 

Holger5

Grünschnabel
ich bin ein wenig verwirrt...
Als ich heute Mittag deine Mail gelesen hatte wollte ich gleich ausprobieren - scolle zurück bis zur Zeile "kvm -hda ..." und drücke ausversehen ENTER statt ctrl-a. Und :suspekt: die Tastatur geht! Ich habe W2k fertig installiert, in Windows vnv-server in den Autostart gelegt, das mir der Bildschirm schickt wird wenn er gebootet hat und starte das immage in tightvncserver: Tastatur wieder vertauscht bei vnc auf X11 und alles Ok im vnc-fenster von Windows :confused:.

Da ich eigendlich W2K-Server haben wollte (für Terminal-Server), habe ich diese installation gerade gestartet und wärend ich auf die Eingabe der Seriennummer gewartet habe schau ich nochmal auf die Ausgaben des Terminalfensters und sehe: "Could not initialize KVM, will disable KVM support" - Ich hatte "modprobe kvm-amd" vergessen...

Ich vermute er macht jetzt nur Emulation a la QEMU und alles klapt aber mit KVM werden die Fehler passieren. Dies wäre mir egal da eh nur per RDP auf der Kiste gearbeitet will. Was mich zu den nächsten Fragen bringt:

(!) 1) Benötigt man X11? oder besser Wie konfiguriere ich die Linux-Kiste am besten, wenn sie beim Booten nur 3-4 Windows-Guest starten soll auf die per VNC und oder RDP zugegriffen werden soll. Auf der Linuxkiste ist keine Grafik nötig.

(!) 2) Gibt es Dokumentation über Taskwechselzeiten und was solche Parameter "isapc" bewirken?
 

Sinac

Erfahrenes Mitglied
Das ist wirklich merkwürdig, solltest du nochmal genauer testen ob das Problem nur ohne KVM auftritt.

1) Du brauchst nicht unbedingt X11, aber damit ist es am einfachsten. Andere Möglichkeiten sind die SDL oder der export über einen VNC Display. VNC macht zum Teil Ärger wenn man hot-migration nutzen will. Auf jeden Fall brauchst du eines davon, irgendwo muss ja die Konsole der VM hin.

2) Dokumentationen gibt es auf den Projektseiten von KVM und QEMU.
 

Holger5

Grünschnabel
Egal ob ich kvm oder qemu aufrufe(wenn kvm-avm geladen ist):

# kvm -hda /w2k/w2kserver.img -hdb /RAM3gb.img -hdc /test1/RAM3gb.img -cdrom /w2k/W2KServer.iso -no-acpi -boot c -m 512

# qemu -hda /w2k/w2kserver.img -hdb /RAM3gb.img -hdc /test1/RAM3gb.img -cdrom /w2k/W2KServer.iso -no-acpi -boot c -m 512

sind die Tasten Verwürfelt:
soll: 12347890qwertzuiopasdfghjkxcvbn,.-
ist : 90ß´qwe8c.gvn*mlyxabfhjköä-d,s#ü+r


will heißen wenn ich die Taste 1 tippe erscheint 9. Tasten mit Sonderfunktionen (z.b. 5 ist Backspace) habe ich weggelassen.