Formatieren mit Netbeans 7.1

maschl

Grünschnabel
Auskommentierter Code sieht zunächst so aus:
Java:
/*
    try {
            v.clear();
            Statement stmt = DB.con.createStatement();
            ResultSet rs = stmt.executeQuery(s);

            while (rs.next()) {
                r = new LfantUmsatzRecord();
                r.inhalt = rs.getInt("Inh");
                r.packart = rs.getString("Pack");
                r.bezeichnung = rs.getString("Bezeichnung");
                r.anzahl = rs.getInt ("Anz");
                r.ek = rs.getDouble("EK");
                r.umsatz = r.anzahl * r.inhalt * r.ek;
                v.add(r);
            }
            * 
            */
Wenn ich jetzt den Code formatiere (ALT + UMSCHALT + F) sieht das ganze so aus:
Java:
/*
         * try { v.clear(); Statement stmt = DB.con.createStatement(); ResultSet
         * rs = stmt.executeQuery(s);
         *
         * while (rs.next()) { r = new LfantUmsatzRecord(); r.inhalt =
         * rs.getInt("Inh"); r.packart = rs.getString("Pack"); r.bezeichnung =
         * rs.getString("Bezeichnung"); r.anzahl = rs.getInt ("Anz"); r.ek =
         * rs.getDouble("EK"); r.umsatz = r.anzahl * r.inhalt * r.ek; v.add(r);
         * }
         *
         */
Ist so natürlich nicht in der Praxis brauchbar. Weiß jemand, wie ich Netbeans dieses Verhalten abgewöhnen kann? Habe trotz eifrigem Suchen nichts gefunden.
 
Zuletzt bearbeitet von einem Moderator:

Akeshihiro

Erfahrenes Mitglied
Moin ^^

Das nächste Mal bitte die Java-Codetags verwenden ^^

Vorweg: Ich bin kein NetBeans-User ...

In den Einstellungen (Tools -> Options) kannst du ja auch den Formatter konfigurieren. Unter Editor -> Formatting wählst du als Sprache Java und als Kategorie Comments, da kannste ein paar Einstellungen vornehmen.
 

maschl

Grünschnabel
Hallo Akeshihiro,
leider habe ich dort keine Möglichkeit gefunden. Hatte ich auch bereits vorher probiert. Trotzdem danke.
Gruß maschl
 

maschl

Grünschnabel
Hallo Akeshihiro,
herzlichen Dank. Hat geklappt. Manchmal ist man regelrecht "blind". Ich hatte die Auswahlbox völlig übersehen und "Comment" nicht eingestellt.
Gruß maschl