egit Remove from Index & gitignore

jimb0p

Erfahrenes Mitglied
Hallo Zusammen,

ich habe mal wieder ein kleines git Problem. Ich möchte in egit gerne ein paar Dateien gar nicht erst mit in die Versionsverwaltung aufnehmen weil das nicht nötig ist und habe folgende .gitignore:

Code:
/bin/
/subtools/
/extended data/
/.classpath
/.project
/caching.ser
*.jpg
*.png
/config.txt
*.html
/extended data/*.html

Aber dennoch werden mir immer die html Dateien aus "extended data" angezeigt zum commiten sowie die config.txt. Selbst wenn ich Rechte MT -> Team -> Remove from Index mache tauchen sie immer beim Commit auf und ich muss sie abwählen. Was genau mache ich falsch?

Wo ich schon dabei bin: Sollte man classpath und project mit ins git aufnehmen?

Grüße!
 

saftmeister

Nutze den Saft!
Funktioniert es, wenn du das Leerzeichen im Pfad mit einem Backslash maskierst?

.classpath und .project gehören eigentlich nicht ins repo, denn so bleibt der Code IDE-unabhängig.
 

jimb0p

Erfahrenes Mitglied
Danke für deine Antwort. Leider klappt das auch nicht. Des weiteren habe ich das Problem, das ich jetzt .classpath und .project aus dem Repository haben möchte. Hier bin ich wie folgt vorgegangen:

1. neuen Branch erstellt
2. RM -> Team -> Advanced -> Untrack
3. Änderungen commited & gepusht

aber die Dateien landen immer noch im Repository. Woran kann es liegen?
 

jimb0p

Erfahrenes Mitglied
Also mit dem .settings Ordner klappt es, der wurde aber bisher auch noch nie eingecheckt. Kann es sein dass ich die html Dateien erst mal wieder irgendwie rausnehmen muss, damit sie ignoriert werden können? Denn die wurden bereits einmal gepusht.
 

saftmeister

Nutze den Saft!
Ich würde es so machen:

1. git rm datei-zu-löschen.ext
2. echo "datei-zu-löschen.ext" >> .gitignore
3. git add .
4. git commit
 

Neue Beiträge