cgi Pfade in der httpd.conf !

Multi-master

Grünschnabel
Hi...
Also...ich habe mir einen Homeserver installiert...diesmal hab ich aber phpTriad genommen...und siehe da...es läuft alles rund,was bei FoxServ 3.0 nicht ging.

Jetzt habe ich Apache und alles was drin ist auf C:\ installiert
Und meine Home auf G:\home (ist auch in der httpd.conf so eingetragen)

Jetzt möchte ich aber auch,das auf dem gesamten G:\ Laufwerk das cgi funktioniert....,und nicht nur in "EINEM" Ordner.....

In der httpd.conf ist ja das eingestellt:
ScriptAlias /cgi-bin/ "C:/Apache/cgi-bin/"

Wie bekomme ich denn jetzt CGI dazu,das er "ALLE" Ordner,die ich vielleicht noch für andere User auf G:/home/ anlegen möchte,das es läuft...

Also ich kann ja z.b auf G:/Home für die Hauptdomäne einen cgi-bin anlegen...
Das kann ich ja dann auch in der httpd.conf bei dieser zeile eintragen....

Jetzt kommt aber jemand...der möchte bei mir Webspace haben,wo ich ihm einen Ordner anlege... z.b G:/home/WebSpaceNutzer/*.* und da noch nen cgi-bin Ordner rein,das er das auch nutzen kann.

Zugriff zu seinem Verzeichnis erhält er ja dann via FTP-Server.

Wie verhält sich das jetzt...hat da jemand Ahnung ??
Wie kann man also cgi multipel vergeben...??
Falls ich noch Zeilen vergessen habe,die editiert werden müssten,dann schreibt es bitte dabei...
Danke schon mal


Bye




[EDIT]
Aber irgendwas funzt net.....
Hab das jetzt in der httpd.cfg eingestellt:


ScriptInterpreterSource registry

ScriptAlias /cgi-bin/ "g:/home/cgi-bin/"
ScriptAlias /php/ "c:/Apache/php/"
ScriptAlias /pl/ "g:/home/cgi-bin/"

<Directory "g:/home/cgi-bin">
AllowOverride All
Options None
Order allow,deny
Allow from all
</Directory>

</IfModule>



Trotzdem bekomme ich eine errormeldung im Browser
wenn ich diese Testdatei aufrufe...

[Sun Oct 06 18:21:24 2002] [error] [client 217.83.93.253] (2)No such file or directory: couldn't spawn child process: g:/home/cgi-bin/printenv.pl

Danke schon mal...bye.....
Ich wollte wegen dem cgi nicht im anderen Forum auch nochn thread starten...bye
 
Zuletzt bearbeitet:

Marcus Roffmann

Erfahrenes Mitglied
Normalerweise sollte es funktionieren wenn Du auf alle Verzeichnisse ein
Code:
Option ExecCGI
hinzufügst. Am besten kannst Du das erreichen indem Du bei jedem neuen Ordner eine htaccess - File mitanlegst in der diese Option eingeschaltet ist.

Lese hierzu:
http://httpd.apache.org/docs/howto/cgi.html

Andere Möglichkeit wäre, dass Du jeden Benutzer extra in die httpd.conf einträgst, aber ich glaube das wäre zu aufwendig. Da kommt die htaccess File schon besser.

Sag halt Deinen Leuten das sie diese File im CGI-BIN nicht anfassen dürfen, sonst geht kein CGI mehr.


Das andere Problem:
Options None erlaubt keine Optionen, also auch kein ExecCGI usw., dann kann auch kein CGI ausgeführt werden.
Sollte so aussehen, dann sollte es funktionieren:
Code:
<Directory "g:/home/cgi-bin">
AllowOverride None
Options Indexes FollowSymLinks MultiViews ExecCGI Include
Order allow,deny
Allow from all
</Directory>
(Kleine Anmerkung: So sieht es bei mir aus und geht)
 

Multi-master

Grünschnabel
hoi
Danke für deine umfragreiche Aufklärung :)
Ich habs dann mit dem htaccess gelassen,und trage jedesmal lieber eine zusätzliche Zeile in der httpd.conf ein...
Dies hat zwar den Nachteil,das man Apache neu starten muss.....aber die Apache-Docu ist so was von "english"...da über schlag ich mich wieder einmal.. :D

Ich machs so:
<Directory "g:/home/cgi-bin"> #Mein Root
AllowOverride All
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
</IfModule>

<Directory "g:/home/users/cgi-bin"> #Kolleges root
AllowOverride All
Options ExecCGI
Order allow,deny
Allow from all
</Directory>
</IfModule>

So könnte man das jetzt fortführen :)

Hatte allerdings erst mal probleme das cgi und pl überhaupt lief...da musste ich bei foxserv.net erst noch mal kramen,wie das mit cgi geht...obwohl ich ja nun phpTriad habe....

Aber kann es sein,das FOXSERV ziemlich Buggy ist ?
Zumindestens was die zusammenarbeit mit php betrifft......
Ich hatte dabei die Probleme,das ich mich in meinem PHPKIT-Portal nach jeder Einstellung neu einloggen musste.....was mit phpTriad jetzt einwandfrei geht....

Oder liegt das eventuell auch daran,das in phpTriad die älteren versionen von php und Apache einfach besser laufen,als die Neueren ??

Also bis jetzt hab ich viel darüber gelesen,das es nur mit FoxServ 2.0 geht,und mit phpTriad.....und wenn ich aus beiden Serverprogrammen die Versionen der Komponenten vergleiche,so sind se gleich....lol

Mit Foxserv 3.0 geht es nicht mehr so gut.....komisch...
Also ist "Neues" nicht gleich immer "Besser"....
Ist manchmal bei Grafiktreibern auch so...
Danke noch mal...
Bye
 

Marcus Roffmann

Erfahrenes Mitglied
Also ich halte weder von FoxServ noch von phpTraid was. Ist zwar schön für Anfänger weil man nicht viel machen muss, aber ich finde ein selbstkonfiguriertes System einfach besser weil man weis was man gemacht hat und wie man es gemacht hat.
Da bekommt man keine Anfälle wenns mal nicht geht sondern kann gleich nach den Problemen suchen.

Sofern ich mal Zeit haben sollte, versuche ich ein Tut für einen WAMP mit CGI (Perl) zu schreiben, kann aber für nichts garantieren. Kann eine Weile dauern.

Nun, noch viel Spaß damit ;)

digi
 

Neue Beiträge